1. Please help us cover the costs of Terra-Arcanum's migration to Xenforo, Guest! More information is available here.
    Dismiss Notice

Arcanum in Vista

Discussion in 'Arcanum Hints & Tips' started by Morgjorg, Mar 2, 2008.

Remove all ads!
Support Terra-Arcanum:

GOG.com

PayPal - The safer, easier way to pay online!
  1. Morgjorg

    Morgjorg New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Mar 2, 2008
    Arcanum installed, patched, nocd cracked and modded just fine for me in Vista, without compatability modes of any kind.

    I did run in to one major annoyance though: the interface was laggy. Everything from menu buttons to dragging and dropping inventory items to the options menu had a split second lag. About a quarter of a second for buttons, and the game had problems redrawing instantaneously when switching menu screens (for example when choosing load game, the screen looked like it was being painted upwards in one large stroke), around half a second.

    I should mention that my pc is stupendously overpowered for this game, so hardware requirements are out of the question.

    The fix? Adding the -doublebuffer launch parameter to my shortcut. Whatever it did, the game is back to its good old self!

    I seemed to be the only person on the net with this problem, but if there are more troubled souls out there, I hope this post can be of some use to them.

    First post at the House of Lords :D
     
  2. Shota Shernokavich

    Shota Shernokavich New Member

    Messages:
    122
    Likes Received:
    0
    Joined:
    Feb 23, 2008
    :eek:

    thanks for the info, though, this fixed my lag when i tried to sleep for longer than an hour (it would take 3x more than usual)
     
  3. GrimmHatter

    GrimmHatter Active Member

    Messages:
    1,274
    Likes Received:
    0
    Joined:
    Dec 27, 2006
    I haven't had that problem on my Vista machine, but that sounds vaguely similar to the speedy overhead map in Fallout games run with overpowered processors. I'm wondering if adding the -doublebuffer to a Fallout shortcut would help that issue too. I don't know what it is with my computer, but I've never had these overclocking problems running older games, or I'd try that myself.
     
  4. trollshade13

    trollshade13 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 24, 2008
    whoever you are, this solves my problem with arcanum on Vista ^^
     
  5. Viktor_Berg

    Viktor_Berg New Member

    Messages:
    319
    Likes Received:
    0
    Joined:
    Dec 23, 2006
    I am no mod, but I do not like gravedigging as well. Not to be rude, but there was no need to dig up a 6 months old thread just to say "thanks".

    ... but thanks.
     
  6. trollshade13

    trollshade13 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 24, 2008
    this was the only solution found to be effective for running arcanum in vista on a laptop (with ATI GPU)
    and spending an afternoon searching to fix the problem... I felt a "thank you" was in a fair thing to say

    But I just read the rule about gravediging... My sincerest apologies for this...
     
  7. Viktor_Berg

    Viktor_Berg New Member

    Messages:
    319
    Likes Received:
    0
    Joined:
    Dec 23, 2006
    Well, yeah, this is a useful thread. I myself run Vista on my laptop (no time/will to install XP yet), and I had terrible lag in inventory/char screen/whatever. -doublebuffer fixed this thanks to this thread.

    But here is an alternative way: you create a new thread, link to the old one and provide your thanks/opinion. It's not that convenient, but at least it stops people from noticing that the topic date is 6 months old.
     
  8. CharlesBHoff

    CharlesBHoff New Member

    Messages:
    1,328
    Likes Received:
    0
    Joined:
    Sep 10, 2001
    Some people told me that you need 8 billionbytes memony with some VISA.
     
  9. Redbloof

    Redbloof New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jan 9, 2009
    I need help

    sorry about posting to this thread but i desperatly need help... I am having the lag problem when I click on inventory and stuff with vista... what the hell are you guys talking about with the doublebuffer thing...what is that? how do i get it? and what do i do after i get it?
     
  10. Redbloof

    Redbloof New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jan 9, 2009
    NVM

    nevermind my brother found out what it ment and it works perfectly now!
     
  11. symban

    symban New Member

    Messages:
    141
    Likes Received:
    0
    Joined:
    Jan 28, 2009
    pls help with Vista

    hi i read all the treads about running arcanum in vista and apperantly ppl here are able to run their arcanums in vista, the thing is that I bought a brand new laptop with great expectations but was shocked as i cant run my arcanum:(
    my problem goes like that (if i dont install 1.0.7.4 patch I get "Arcanum.exe stopped working" as soon as i run) after installing patch I run arcanum and get no error, but nothing happens(at first i thought it closed down without warning, but i see arcanum.exe running in task manager). pls can you tell me what you did to run(the compability mode options u set) and especially how to make that doublebuffer thing. i dont have a brother to help me with it neither :p
    I m really looking forward to play so pls help me
    (my comp is a 1720 Dell inspiron, can run baldurs gate after some setting changes but cant many old DirectX games like mediaval 1, if it has anything to do with hardware itself?)
     
  12. magikot

    magikot Well-Known Member

    Messages:
    1,686
    Likes Received:
    2
    Joined:
    Aug 29, 2003
    symban, to run it in compatability mode, right click the shortcut select properties then select the compatability tab. Check the box that says "run in compatability mode" and from the drop down menu select Windows XP (Service Pack 2). Works perfect for me that way on my 32 bit OS of Vista.

    If, however, you have the 64 bit you may be screwed. You'll need to do all of the above as well as run it as administrator or even have to run it in safe mode.
     
  13. symban

    symban New Member

    Messages:
    141
    Likes Received:
    0
    Joined:
    Jan 28, 2009
    tx but still same:(

    ty for the quick answer but i already tried most of the compability mods as well as many combinations of them with other check stuff(like disable desktop composition etc) but as i run it nothing still happens(no error message or game screen, but i see arcanum.exe in task manager) also can u tell me about the "doublebuffer" pls, i have no idea how to do it
    tx for your caring:)
    (btw i also have 32 bit)
     
  14. geminisama

    geminisama New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jan 30, 2009
    After replaying Fallout 2, I got the urge to play Arcanum again. I was aware of the menu lag and such on Vista, and I decided to bear with it, 'til I stumbled across this thread. The OP is a GOD, as this fixed all my issues.

    To Symban, here's what you do. Assuming you have a shortcut on your desktop, right click the exe, and click properties. There will be a box labeled, "Target", with C:\Sierra\Arcanum\Arcanum.exe. In this box, type a single space after the exe and then type -doublebuffer

    Press APPLY at the bottom, and you're all set. Enjoy.
    :)
     
  15. Malavon

    Malavon New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Feb 6, 2009
    Hi,

    I have the problem, that i not even can install the game on my notebook. (Dell M1710 with Vista Ultimate 32bit)
    On my old PC, with Wndows Xp Sp3, the game runs without any problems.

    I just get a message, that some "transform pathes" are not possible.

    I hope you can help me.

    greetz, Malavon

    Ps: sry for the bad english... i didn't spoke or wrote for a long time.
     
  16. Andkatus

    Andkatus New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Feb 18, 2009
    I have Vista 64 bit and I've tried all of the solutions listed on these boards, but none of them, including that listed in the OP, have worked. While Arcanum itself boots up fine, I still get the severe cursor slowdown and general menu bugginess previously described. When I try to add -doublebuffer to the target, I get flickering, artifacts, half the screen disappearing, and an array of other bugs. Running in 640X480, Compatibility mode XP SP2, and Running as Administrator don't effect any appreciable improvement. Are there are any other known solutions to Arcanum's Vista 64-bit issues?
     
  17. DarkFool

    DarkFool Nemesis of the Ancients

    Messages:
    3,997
    Likes Received:
    3
    Joined:
    Jan 28, 2005
    Congratulations! You're the fourth person to gravedig this thread! I won't even bother to lay into you, you'll possibly be banned outright. :) Anyway, before you're gone, I'll provide you with some help, since by digging this up, you've technically given me a few things to try for some improved performance on my machine. Firstly, have you read through the thread that was stickied? Have you tried everything there? Secondly, what patch are you running? Do you know?
     
  18. Andkatus

    Andkatus New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Feb 18, 2009
    Erm, I don't exactly see how bumping a 10-day old thread (with respect to the last post/update) directly relevant to my issue constitutes "gravedigging". This is the most recently updated non-stickied (I'm hesitant to bump stickies both because I find that people tend to have difficulty noticing them on most forums and because I find that doing so isn't welcome on some forums) thread on the topic, and I see no reason to start a new one about the exact same issue. And yes, I have read and tried all of the solutions in the stickies (hence my reference to "all the solutions on these boards"- a bit of an exaggeration, but I did look through all the modern/stickied threads on the topic), and I am using the official patch. I don't see why you feel the need to be so peremptory about this.
     
  19. DarkFool

    DarkFool Nemesis of the Ancients

    Messages:
    3,997
    Likes Received:
    3
    Joined:
    Jan 28, 2005
    Because that was a 10-day old gravedig, that you then gravedug. :) However, nobody seems to have noticed, so let's do our best to help you. Also, given that this pertains to Vista, I actually was hoping to get it all in one thread: my intent was to modify that main post to include any/all solutions we concocted. Are you still having issues? I apologize for my lack of reply until now: I've been rather busy with work. I'm willing and able to help you though, provided you didn't flee our forums after noting no response to this. Are you able to start an actual game, and it lags, or does the main menu load and run slowly, but nothing ever functions beyond that? Also, are you running 64bit or 32, and which version?
     
  20. Andkatus

    Andkatus New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Feb 18, 2009
    64-bit. I can start games just fine and the actual gameplay (i.e., combat, movement, etc.) doesn't lag. However, anything involving menus or the cursor lags horribly- actually starting a game, changing options, manipulating the inventory, etc. is an incredibly slow and tortuous process.
     
Our Host!