1. Please help us cover the costs of Terra-Arcanum's migration to Xenforo, Guest! More information is available here.

Is it still worthy to make a mod in english ?

Discussion in 'Arcanum Discussion' started by Wims, Jun 18, 2011.

Support Terra
Arcanum:
Good Old Games
 
 
  1. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Well... Yes... It's bugged...
    You got an old testing version...

    Here is the correct link. I apologize for that and, to be forgiven, I made the extended demo even longer !

    Enjoy !

    http://www.mediafire.com/?5vrvbyoa2f0wsrn /!\ new data folder /!\

    - Wim's

    EDIT : I know about pre-made character but remove them make the game crashes if you click on "choosing a pre-made character"... Who play with 'em anyways ? (Except me for testing purpose... I always take Victoria Warrigton, especially if the is a deadly trap, I HATE her.) Seriously, I'm working on making the pre-made characters normal.
     
  2. wayne-scales

    wayne-scales Well-Known Member

    Messages:
    1,263
    Likes Received:
    1
    Joined:
    Aug 2, 2007
    Possibly my stupidity, but I thought I'd check whether I was genuinely stuck or if this is a bug.

    I'm in the mine-type place, and I can't get the oil to flow. I've replaced two of the pipes and pressed the switch to open the lock, but the third pipe has a hole in it; so, I ventured further to the passage beyond the machine with turbines, but cannot get through, with no comment from my character as to why.

    Is this my missing something, or a bug?

    Also, saving really seems to mess the module up... If I save, or try to load the Auto-Save, the next time I try to select the module in Options, it won't allow me to click Done (or any other option, for that matter), though it is not frozen. The only way I have to fix this is to exit the game, open the modules folder, and delete the Extended_demo_fixed (or whatever it's called) folder, and I haven't figured out any way to save the game.


    Edit:

    On a second playthrough,

    I decided to fight the undead creature that emerge from a hole in the ground, only to find out that he's a follower: Jack (I had previously accidentally clicked on the hole and couldn't get back up), who does comment on the passage; however, I suppose you could make the character comment on it if Jack isn't a follower, just to clear up some confusion... I'm going to play through one more time because I have an idea about the pipes; but if I don't edit again, I'm still stuck and so still wondering whether or not it's a bug.

    Also, it seems that I need to delete the folder in the modules folder each time I want to play it, whether I save or not...
     
  3. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Thanks for the feedback. The weird thing is that everything is fine when I play with the folder of the mod i.e not the compressed .dat

    I will have a look at the bug load/save.... errr....

    For the other problem, it is not a bug :D with my brother, we managed to introduce a new gameplay mechanism... You can now use an item on another item in your inventory to solve riddles...

    About the passage you couldn't venture on, I will add a float line.... YOu nedd a mine cart to go there and Jack told you so if you go in this part with him as a follower.

    Except for this nasty bug load/save, did you enjoy the mod ?

    EDIT : the bug only happens with the .dat so I have to figure out why... Meanwhile, you can play with this :

    http://www.mediafire.com/?0r2yd5qi3350i7z

    It is the original folder of the mod. It is not bugged as far as I know...
     
  4. wayne-scales

    wayne-scales Well-Known Member

    Messages:
    1,263
    Likes Received:
    1
    Joined:
    Aug 2, 2007
    Fuck... I should've fucking thought of that!

    It's brilliant; I can't wait to play the whole thing!

    Yep; that fixed it.
     
  5. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Thanks for the feedback. I'm glad you like it !

    I am currently working on your suggestions to add float lines if the player is alone in the mine. Hard scripting work indeed.
     
  6. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Hey guys,

    just to say I'm still working on the mod. I am also writing a paper for university (100 pages :roll: ) so it does not go as fast as I wish but the first part of the mod is almost done !
     
  7. TheDavisChanger

    TheDavisChanger Well-Known Member

    Messages:
    1,740
    Likes Received:
    1
    Joined:
    Feb 6, 2009
    How's that paper coming along? I took French in high school so I could help you write half of it or so.
     
  8. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Are you skilled about UNCTAD Model Law on Competiton and its forseenable consequences on macro-economics systems and politics resistances ?

    Anyway, the module goes on.
     
  9. TheDavisChanger

    TheDavisChanger Well-Known Member

    Messages:
    1,740
    Likes Received:
    1
    Joined:
    Feb 6, 2009
    No. Even if I were to write half of your paper in English, it wouldn't be very good.
     
  10. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    The mod will features in some secret way Crypton to thanks him for his huge help...

    I will likely launch a contest on Monday to give to those of you who are interesting a chance to also be featured on the mod. You will be able to be almost anything or anyone you want !

    Don't miss your chance to be on the mod ! Stay tuned !

    + dev news : I am almost celebrating my 200th script. The first part on six of the mod is nearly done ! It will probably takes 1 hour to reach the end of the first part.
     
  11. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Hello guys !

    I'm late but here is the contest !

    Code:
    In which city can we found the Three Loaves Public House & Inn ?
    Send me a private message with your answer and the first one with the right answer will be featured into the mod !

    I have finished the first part of the mod ! I have almost 250 scripts and it should take more than 1 hour to reach the end and there is several changes depending on answers you gave at the beginning of the mod.
     
  12. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Muro won the contest ! Congrats Muro. You will be on the mod !

    I will likely launch another contest in few weeks. Stay tuned !

    EDIT : I will soon record the dialogs dubbing for the first part of the mod. Send me a private message if you want to be involved ! You will be credited for that ! If you have a preference for the kind of voice you want to record, tell me so !
     
  13. random1

    random1 New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Nov 19, 2010
    I can't try this one out at the moment, but from what I read here this looks very good so far.

    I commend you on your dedication and I, like others here, hope you continue it.
     
  14. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    I've done the first part and I will likely soon upload it. I'm going to Tokyo for one year soon and I will have 1 000 000 better things to do than modding so it will stay asleep for a year at least.

    I am also currently writing my thesis so I don't have time now to continue it. But it is not definitly dead. :thumbup:
     
  15. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    I'm not dead. Just finishing my thesis.

    Will upload the first part next week or so.
     
  16. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    Hello !

    For those who remember, I started to create a mod months ago and, as I wrote on the forum, I didn't resume it yet since I am still in Tokyo for a one year exchange program (going till July). I don't know if I will resume the creation of the mod.
    I am also busy translating my brother's mod (lots of dialogs) : CrossRoad

    But here is the link of the complete first act of my mod. I wanted to upload it for a while but I have been very busy.

    Feel free to report bugs or comment

    EDIT2: please see below for proper links.

    - Wim's
     
  17. Jojobobo

    Jojobobo Well-Known Member

    Messages:
    2,160
    Likes Received:
    10
    Joined:
    May 29, 2011
    Hey I've played through what I could and now I'm stuck...

    I fell asleep on the bed and had what appeared to be a dream and now I've got no items and as far as I can tell no where to go. If you could give me some advice on how to proceed that would be great because I've tried everything I can think of, unless this is the end of this part of the mod?

    I also never managed to get the room with the black chests open at the start of the game as I couldn't find anything to go on the pedestal, I did however collect all 3 black keys which I presumed worked on those chests - is there anyway yet to get in there and open them or will that be a later part of the module?

    Also I noticed when you are clinging to the rock in the water flow that you get the option to dump your items, however the only way I succeeded in getting past this point (had to reload a few times) was to keep all my items and continue trying to cling on repeatedly. After you get swept into the cave your character remarks that they lost all their items but their keys - which as I said was not the case for me as I retained all of mine. I didn't know if this was a bug or not? It appeared as if I couldn't proceed if I did dump anything, as the message to try and cling/hang on came up over twenty times when I did dump items - seemingly not letting me progress - or the cave did load up eventually but the character sprite was no where to be seen.

    Lastly although I levelled up I could not spend character points, I did not know if this was intentional? I was using Merwin Tumblebrook so I don't know if that changes anything.

    On the whole the mod is very enjoyable and the puzzles are a lot of fun. It was really good how the environment you have created is much more interactive than in the standard game. The english in the module is very good seeing as you translated it all and I only noticed a few minor mistakes, but even in those instances I was still perfectably able to understand what you meant. Also...

    I really liked the part with the incinerator; it was a bit hair raising to try and kill all of the spiders in it and it took a few tries!

    Thanks a lot for the first act of what I'm sure will be a great module when finished!
     
  18. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    It's near the end but you should be able to finish this part... I have to re-test the mod again. Some script probably gone wild but it worked the last time I played...

    Congrats for finding all 3 black keys on the first game. I guess I should hide some key better. Also, I don't remember if I put the "thing" to open the door yet so I will check it out.

    This is definitely a bug. Got to ckeck this script...

    Oh, I forgot to tell people to NOT choose a pre-made character... I'll check this out.

    If you remember some of the mistakes, I'd fix them

    I actually have some motivation to resume the creation. I don't promise anything but...

    Thanks for playing and for commenting !
     
  19. Jojobobo

    Jojobobo Well-Known Member

    Messages:
    2,160
    Likes Received:
    10
    Joined:
    May 29, 2011
    I think they were all reasonably well hidden, I don't think I would have found the first one if I didn't search particularly thoroughly. As a minor point for whatever reason the one on a body of a defeated skeleton didn't have the artwork of the other two for whatever reason.

    As I said you didn't make any glaringly obvious mistakes anyway so I can't remember any off hand; if I play through again soon though I'll make sure to note down anything specific that I find.

    You definitely should try and finish when you have the opportunity but only when time allows as it sounds like you have a busy enough schedule as it is! It certainly is a very unique module in terms of gameplay.
     
  20. Wims

    Wims New Member

    Messages:
    161
    Likes Received:
    0
    Joined:
    Jun 13, 2011
    The last time I used WorldEd was several months ago... I probably forgot a lot but nothing I can not learn again...

    I'm busy write now, just living in Tokyo and I am also translating my brother's mod : CrossRoad. Hundreds of dialogs...

    But I'll try to resume the creation soon. Thank you for your enthusiasm :)
     

Share This Page