1. Please help us cover the costs of Terra-Arcanum's migration to Xenforo, Guest! More information is available here.

Arcanum:WIP 2.2 (Beta) Now Available

Discussion in 'Module Discussion' started by rroyo, Oct 28, 2007.

Support Terra
Arcanum:
Good Old Games
 
 
  1. wayne-scales

    wayne-scales New Member

    Messages:
    1,262
    Likes Received:
    1
    Joined:
    Aug 2, 2007
    Lines 81 and onward are missing. For me, at least.

    The answers to questions about the Minsk family and Roseborough are also blank.
     
  2. Aal-Bundee

    Aal-Bundee New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Feb 6, 2008
    rroyo,

    Haven't been idle since my question about the binkw32.dll & mss32.dll dilemma when trying to play in the full screen mode-I had researched and tried the links/solutions that you provided (thanks for your quick response-as usual) before I posted the question, so I went back to square one-more web research then re-formatted my hard drives, installed basic 98SE and drivers, tried different versions of audio/video drivers and directx to no avail-reinstalled a Drive Image copy of 98SE with all updates, did the vid/aud/directx again to no avail. All these were tried multiple times as well as multiple re-formats. OK Started over again and used my XP update disk and did all the aud/vid/directx installs again. No go. Still got binkw32.dll missing etc. etc. after all these attempts. I should also mention after all these different installs I tried the solutions that Xz had documented-I did find from my web research to use the "system" file rather than the "system32" when using 98/98SE.
    I was resigned to not using the full screen mode so I re-formatted and installed a Drive Image (Great program by the way) copy of 98SE with the last available drivers for 98SE, but instead of letting the install disk use my D drive (the default) for the installation, I used my C drive-DOH!!-all is well, your WIP2.2 runs in full screen-well, that's my story, your mileage may vary.....
    During this process of install uninstall ad nauseum and perusing the net and these forums, I decided to copy my install/run disks (bought new 8/31/2001) for protection-the problem is that when I try to use it (the copied run disk), it displays the run screen, the drive starts up but it won't start the game, it just stays at the desktop-a side by side properties of both disks show them to be identical down to the last byte-661,454,848. I should add that I can use both copies (not the originals) to install the game and the original will start/run where the copy won't-have looked on the forums for this problem and couldn't find it-am I SOL?-Aal
     
  3. rroyo

    rroyo Active Member

    Messages:
    3,319
    Likes Received:
    0
    Joined:
    Oct 13, 2006
    Aal: Glad to hear you got it working. Enjoy.

    Early on I made an attempt to create a back-up copy of my install disks and learned that they wouldn't work right either. I managed to narrow the possibilities down to either the disks needing to have specific volume numbers or there's some kind of hidden anti-copy in place that prevents you from making a back-up.
    And that's as far as I ever got. Sorry.
     
  4. rroyo

    rroyo Active Member

    Messages:
    3,319
    Likes Received:
    0
    Joined:
    Oct 13, 2006
    Yep! Double post.

    Wayne: I've been trying various characters, alignments, genders, and IQ's off and on for half the night and I can't get your problem to come up.
    I suspect it's in your game.

    Try this: Take a save from before you went to Roseborough and talk to Xiao. If you have no earlier save, then exit the town, return in a few days, and talk to Xiao again.

    Let me know if you have the same thing happen.
     
  5. wastelandhero

    wastelandhero New Member

    Messages:
    242
    Likes Received:
    0
    Joined:
    Aug 16, 2007
    I downloaded/reinstalled this just last week after doing an overhaul on my comp. and was wondering if you had changed anything with the zombies in the Ashbury cemetery? I played as normal, when reaching Blackroot, hopped the train to Ashbury to pick-up Dog early, then I normally went to the cemetery to do some leveling. This time around there were only 2 zombies near the gate and no others popped up even after letting the game run unattended for an hour. Was this changed? It seems rather wierd.
     
  6. rroyo

    rroyo Active Member

    Messages:
    3,319
    Likes Received:
    0
    Joined:
    Oct 13, 2006
    Sorry guy, but I didn't do anything to the graveyard.

    Is anyone else having this problem?
     
  7. wayne-scales

    wayne-scales New Member

    Messages:
    1,262
    Likes Received:
    1
    Joined:
    Aug 2, 2007
    rroyo, are you going to be taking any ideas from the Russian expansion? I saw a few of the screen shots and some look interesting..

    Also, do you know when the next installment of WIP will be released?
     
  8. rroyo

    rroyo Active Member

    Messages:
    3,319
    Likes Received:
    0
    Joined:
    Oct 13, 2006
    1) Only in the most generalized way. Now, I do plan to add a Bank of Tarant and the item retrieval from the small temple GG added was fairly straight-forward enough, but I don't think there will be any scenes that look close enough to his work for direct comparison.

    Also - Since everything was written in Russian, I wasn't able to learn too much about the new adventures beyond what I could discern by looking at the scene.

    2) Perhaps by the end of the month - if all goes well.

    I'm scaling back the Plainwicke adventure until I can get a few more places - like the other banana plantation - built, adding 3 more hobbit-holes to Brandybuck - with people, and, of course, there's the real-world demands on my time.

    So, barring a major problem, everything should be ready and de-bugged before April.
     
  9. wayne-scales

    wayne-scales New Member

    Messages:
    1,262
    Likes Received:
    1
    Joined:
    Aug 2, 2007
    Cool.

    By the way, I was playing Arcanum today, and noticed that the description for Intelligence says that it is a limiting factor in the learning of spells and the technology gear. But it doesn't affect spells at all!!! Can this be easily fixed? Because mages are overpowered anyway.
     
  10. Hans Maulwurf

    Hans Maulwurf New Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Jan 8, 2008
    Intelligence does influence magic because (as far as I know) the number of active spells you can have is Int / 4.
     
  11. Dark Elf

    Dark Elf Administrator Staff Member

    Messages:
    10,094
    Likes Received:
    1
    Joined:
    Feb 6, 2002
    You also need an Intelligence at 5 or above to cast any spells at all. Considering that only half-ogres, pit fighters and supermodels score that low Int doesn't mean shit to the artillery mage or the magick healer. Summoners and buffers find INT relevant though.
     
  12. wayne-scales

    wayne-scales New Member

    Messages:
    1,262
    Likes Received:
    1
    Joined:
    Aug 2, 2007
    But don't you agree that magic easily over-powers tech? I think the spells should be harder to get.
     
  13. Dark Elf

    Dark Elf Administrator Staff Member

    Messages:
    10,094
    Likes Received:
    1
    Joined:
    Feb 6, 2002
    There are essentially three spells that make magick overpowered. Harm, Fireflash and Disintegrate. They could definitely stand some nerfing. Meanwhile, there are other spells that are absolutely useless. Ever tried using Stone Throw as your primary attack spell? That's some atrociously low damage per mana spent.

    But in all essence, fix Harm, Fireflash and Disintegrate and you have a fairly balanced system.
     
  14. wayne-scales

    wayne-scales New Member

    Messages:
    1,262
    Likes Received:
    1
    Joined:
    Aug 2, 2007
    The higher spells should be more powerful, but a lot harder to get! What do ya think?
     
  15. rroyo

    rroyo Active Member

    Messages:
    3,319
    Likes Received:
    0
    Joined:
    Oct 13, 2006

    Here's the listing for Fireflash:

    // 22 -- Fireflash
    -2100--AoE: Tgt_Obj_Radius, Radius: 2- // Missile
    //-2100--AoE: Tgt_Tile | Tgt_Obj_Radius, Radius: 2- // Missile
    {2100}{AoE: Tgt_None, [Begin]AoE: Tgt_Tile | Tgt_Obj_Radius | Tgt_Obj_No_Self | Tgt_Obj_No_T_Wall | Tgt_Non_Party_Critters, [Begin]Radius: 2, [Callback]AoE: Tgt_Summoned} // Missile
    {2101}{Cost: 15, Resist: (stat_constitution @ -5), Info: aggressive}
    {2102}{Missile: 0}
    {2104}{AI_Offensive: 13}
    {2105}{[Begin], AoE: Tgt_Obj_Radius | Tgt_Obj_No_Invulnerable | Tgt_Non_Party_Critters, Type: Damage, DmgType: Dmg_Fire, Dmg: 15-45, Dmg_Flags: Scaled}
    {2106}{[Begin], AoE: Tgt_Obj_Radius | Tgt_Obj_No_Invulnerable | Tgt_Non_Party_Critters, Type: EyeCandy, 2, Add}
    {2107}{[Begin], AoE: Tgt_Obj_Radius | Tgt_Obj_No_Invulnerable | Tgt_Non_Party_Critters, Type: EyeCandy, 3, Add, Play: Stack}
    {2108}{[Begin], AoE: Tgt_Tile_Empty, Type: Summon, Proto: 4050}
    {2109}{[Begin], AoE: Tgt_Tile_Empty, Apply_AoE: Tgt_Summoned, Type: EyeCandy, 2, Add, Play: Callback}
    {2110}{[Callback], AoE: Tgt_Summoned, Type: Destroy, Summoned Object}

    If I'm reading this correctly, then resetting the damage levels on line 2105 to - say - Dmg: 5-15 should make this spell more realistic.

    Can anyone confirm this or is there another file beside SpellList to keep things in line?

    Edit: I just took a look at the Dark Magic hack and it has Fireflash damage reset to 30-60. Has anyone used the hack and can confirm these damage levels?
     
  16. wastelandhero

    wastelandhero New Member

    Messages:
    242
    Likes Received:
    0
    Joined:
    Aug 16, 2007
  17. rroyo

    rroyo Active Member

    Messages:
    3,319
    Likes Received:
    0
    Joined:
    Oct 13, 2006
    The best I can say is the odds are 50/50.

    Now, with the release I will include instructions that'll give you your best chance to use an old save, but I have modified Brandybuck, Dernholm, and the landing spot on Cattan.

    Any save made prior to going to those locations should work but I've had my test saves corrupted 3 or 4 times by these changes already.
    And I start from the Crash Site.
     
  18. Spiffy

    Spiffy New Member

    Messages:
    456
    Likes Received:
    0
    Joined:
    Aug 19, 2007
    I haven't noticed any changes to Durnholm :/
     
  19. rroyo

    rroyo Active Member

    Messages:
    3,319
    Likes Received:
    0
    Joined:
    Oct 13, 2006
    You won't in the 2.2 release.
    I extended the dock and added a ship for passage to Cattan - which will be in the upcoming version.
     
  20. Spiffy

    Spiffy New Member

    Messages:
    456
    Likes Received:
    0
    Joined:
    Aug 19, 2007

Share This Page